A Guide to QuarkXPress 2018

Collaboration and single-sourcing

You can use the synchronization feature to easily package the same information for distribution in multiple formats and through multiple channels. In addition to customizing designs according to medium — print and digital — you can also create projects that contain multiple layout sizes. Best of all, you can streamline your work by automatically synchronizing your content between layouts of any type.

Working with shared content

If you've ever worked on a project where the same content needs to be maintained identically in multiple places, you know there is a certain degree of risk involved. What if the print version of a document is updated, but the digital version is not? To address this problem, QuarkXPress includes the shared content feature. This feature lets you link content that is used in different places within a project file. If one copy of the content changes, the other copies are immediately and automatically updated to reflect those changes.

For most synchronized items, QuarkXPress maintains a master version in an invisible part of the project file called the shared content library. When you make a change to any synchronized item in a layout, that change is written to the master version in the shared content library, and then QuarkXPress automatically updates all synchronized copies of that item in the project to reflect the change. So if you update item A, item B gets updated automatically via the master item in the shared content library — and if you update item B, item A is updated the same way.

The shared content library can hold pictures, boxes, lines, formatted and unformatted text, chains of text boxes, groups, and Composition Zones. When you add something to the shared content library, you can control which aspects of that content or item should be synchronized (kept the same in every instance) and which aspects should not be synchronized.

The shared content library contains text, pictures, lines, Composition Zones, and items that can be used in different layouts within a project. When you change any instance of a shared content library item in a layout, all instances in all layouts are automatically updated because they are all linked to the master version in the shared content library.

Items in the shared content library are displayed in the Content palette. From this palette, you can duplicate and synchronize that content across different layouts, as illustrated below.

The Content palette provides access to items in the shared content library. Here, "Print Layout 1" uses "Top Story Picture Box" and the picture within it, but "Print Layout 2" uses only the picture itself (in a larger picture box). If the picture changes in either layout, both layouts are updated automatically.

For information about including different types of layouts in a single project, see "Projects and layouts."

Sharing and synchronizing content

To share and synchronize boxes, lines, groups, and content:

  1. Display the Content palette (Window menu).

  2. Select the items you want to synchronize.

  3. Click Add Item in the Content palette. If one item is selected, the Shared Item Properties dialog box displays. If multiple objects are selected, the Share Multiple Items dialog box displays.

    Use the Shared Item Properties dialog box to share and synchronize individual items.

    If Automatically show selected items in the layout is checked, you can navigate to an item by clicking its name in the list.

    Only the attributes of shared lines can be synchronized.

  4. To share the characteristics of a selected item, check Synchronize Box Attributes for that item.

  5. To share the text or picture in a selected item, check Synchronize Content for that box. To share both the text or picture and its formatting, click or choose Content and Attributes. To share only the text or picture, click or choose Content Only. See "Understanding synchronization options" for box and content options.

  6. Click OK to add the selected items to the Content palette.

    The Content palette provides access to the items and content in the shared content library.When you share the content in a text box, the complete text will be shared, it is not possible to share a fraction of text. If you need to share only part of the text, then you should be using a content variable. Content Variables allow you to achieve that using a custom variable.

Understanding synchronization options

When you add items and content to the Content palette, you can choose various synchronization options in the Shared Item Properties dialog box.

  • To synchronize the content of the selected text box, text path, or picture box without synchronizing the box or path itself, uncheck Synchronize Box Attributes and check Synchronize Content. Text synchronized in this way must be dragged into a text box or path, and pictures synchronized in this way must be dragged into a picture box.

  • You can synchronize the text or picture and its content attributes (such as, formatting for text and scaling, rotation, and effects for pictures) by clicking or choosing Content and Attributes.

  • You can synchronize the text or picture while allowing unique content attribute edits by clicking or choosing Content Only. If you do this, the text or picture can be formatted differently in different parts of the project. But if you edit the text or update the picture in one place, that change is made everywhere.

  • To synchronize a text box, text path, or picture box and its attributes without synchronizing its contents, check Synchronize Box Attributes and uncheck Synchronize Content. For example, assume you do this with a text or picture box, and then drag out two copies of the box. If you then resize and add a frame to one of the boxes, the other box is automatically resized and acquires the same frame. You may, however, import different content into each box.

To synchronize item attributes, content, and content attributes, check Synchronize Box Attributes and Synchronize Content, and click or choose Content and Attributes. If you synchronize two boxes this way, any change made to one is automatically made to the other, including changes to box size, contents, and formatting.

Placing a synchronized item

To place a synchronized item or group:

  1. Select the target entry in the Content palette.

  2. Drag the Content palette entry onto the page.

Placing synchronized content

To place synchronized content:

  1. Select a text box, text path, or picture box.

  2. Select the text or picture content entry in the Content palette and click Insert. Note how the item's resizing handles change to synchronization symbols. You can also drag the text or picture entry from the Content palette to an active text box, text path, or picture box.

You can also drag the text or picture entry from the Content palette to an active text box, text path, or picture box.

Importing content into the shared content library

In addition to importing text or pictures into text or picture boxes, you can import content directly into the Content palette using the Content palette's Import button . However, this button is available only when you select a text content icon or picture content icon in the Content palette.

Text imported this way becomes embedded in the project file; no link to the source text file is maintained. Pictures imported this way, however, can be viewed and updated in the Pictures pane of the Usage dialog box.

Working with Composition Zones

The following topics show how Composition Zones can streamline existing workflows by allowing team members to work on the same QuarkXPress project at the same time.

Understanding Composition Zones

A Composition Zones item is a layout or user-defined area within a layout that can be shared with other QuarkXPress users.

Imagine a layout artist in charge of the QuarkXPress project files for a magazine. The layout artist can use Composition Zones to share content with writers, editors, graphic artists, and remote contributors who also use QuarkXPress.

Using QuarkXPress, the layout artist can "draw out" the area of the project for an ad using the Composition Zones tool and then export that Composition Zones item as a separate file. The resulting file includes the correct specs, and this approach saves steps when the remote ad creator receives the file. The ad creator works in QuarkXPress to add the content and then returns the file — along with necessary graphics and fonts — to the layout artist. The layout artist then places the updated file in the proper folder, and the layout is updated automatically to show the ad. And because the Composition Zones item works just like a QuarkXPress layout, the layout artist can open the file to make changes.

Meanwhile, the layout artist can designate another Composition Zones item for an article on the same page as the ad. The layout artist draws three boxes: One for the headline, one for the body of the article, and one for a picture. Using the Shift key to select all three boxes, the layout artist creates a new Composition Zones file from those three boxes, exports that file, and then notifies the writer that the file is available in the staff's shared network folder. As the writer works with the file and saves each updated version, the updates display in the layout artist's project. And like the advertisement, the article can be edited later in the project.

Top: The main layout artist exports parts of a project as Composition Zones, and then sends one file through e-mail to a remote ad designer and puts another file on a local networked server. Middle: The main layout artist, the reporter, and the ad designer all work on their parts of the page simultaneously. Bottom: The ad designer sends the completed ad to the main layout artist in an e-mail message, the page updates automatically, and the layout is done.

The scenario above shows the primary uses for Composition Zones, but the feature can accommodate other collaborative workflow issues as well. For example, Composition Zones can be restricted to the project where they are defined, which you might want to do for a number of reasons. Perhaps the layout artist wants to use an ad in more than one place in the project, and the ad might include multiple text and picture boxes. You cannot use the Content palette to synchronize a group of items, but if the layout artist creates a Composition Zones item based on a selection of multiple items, that Composition Zones item becomes synchronized and available for use throughout the project. Maybe the layout artist designates one layout for the printed magazine and another layout in the same project for a digital page that includes the ad. The layout artist can restrict the use of this Composition Zones item to this single project, but the ad can match exactly in print and digital output.

Composition Zones terminology

Composition Zones are unique because they have the characteristics of items when you place them in a layout, but they behave like layouts when you edit their contents.

  • Composition Zones item: An item that shows the contents of a layout that exists elsewhere. You can think of a Composition Zones item as a "window" through which you can see the contents of a different layout. The layout shown in a Composition Zones item is called its composition layout (see next definition). Each Composition Zones item gets its content from one (and only one) composition layout.

  • Composition layout: A special kind of layout that is used only to provide contents for a Composition Zones item. You can think of a composition layout as the layout that is visible through the "window" of a Composition Zones item. Multiple synchronized Composition Zones items can display the contents of a single composition layout. However, a composition layout can be edited by only one person at a time.

When you create a Composition Zones item, QuarkXPress automatically creates a composition layout to provide content for that Composition Zones item.
When you add content to a composition layout, it automatically updates any corresponding Composition Zones items. The updates display in the Composition Zones items according to the preferences that are set for the layouts that contain the Composition Zones items (immediately, at print time, or when opening the project).
  • Original Composition Zones item: The initial layout or user-defined area from which a Composition Zones item was created.

  • Placed Composition Zones item: A Composition Zones item that you have positioned in a layout using the Content palette.

  • Original host layout: The layout where a Composition Zones item was created.

  • Host layout: Any layout into which a Composition Zones item has been placed.

Creating a Composition Zones item

You can use three methods to create a Composition Zones item (and its corresponding composition layout):

  • You can select multiple objects and then choose Item > Composition Zones > Create.

  • You can designate an entire layout as a Composition Zones item.

  • You can select the Composition Zones tool and manually outline the space for your Composition Zones item.

The following topics show all three methods for creating a Composition Zones item, in this case for exclusive use within one project (that is, a single-project composition layout).

Creating a Composition Zones item from a selection of multiple items

To create a Composition Zones item based on a selection of multiple items:

  1. Select the Item tool or a Content tool , press the Shift key, and select more than one item.

  2. Choose Item > Composition Zones > Create. A box that equals the size of the bounds of the group replaces the group.

  3. To finish creating the Composition Zones item, choose Item > Share, or display the Content palette (Window menu) and click Add Item. Either way, the Shared Item Properties dialog box displays.

    Use the Shared Item Properties dialog box to name your composition layout and designate availability.

  4. Enter a name for the composition layout in the Name field.

  5. Choose This Project Only from the Availability drop-down menu.

  6. Check Show Tab in Project Window to provide access to the composition layout from the layout tab at the bottom of the project window.

  7. Click OK to save the composition layout.

If the position of one or more selected items is locked (Item > Lock > Position), then you cannot create a Composition Zones item.

Creating a Composition Zones item from a layout

To create a Composition Zones item based on an entire layout:

  1. Display the layout you'd like to designate as a Composition Zones item (for example, "Layout 1").

  2. Choose Layout > Advanced Layout Properties.

  3. Check Share Layout.

    Use the Advanced Layout Properties dialog box to specify sharing for a composition layout that is based on an entire layout.
  4. Choose This Project Only from the Availability drop-down menu.

  5. Check Show Tab in Project Window to display the composition layout for easy access from the layout tab at the bottom of the project window. If you uncheck Show Tab in Project Window, you can access the composition layout by selecting the Composition Zones item and choosing Item > Composition Zones > Edit.

  6. Click OK. The composition layout displays in the Content palette.

    A composition layout may contain multiple pages. You can use the Page menu or the Page Layout palette to add, delete, or move pages.

Creating a Composition Zones item with the Composition Zones tool

To manually define a Composition Zones item:

  1. Select the Composition Zones tool in the Tools palette.

  2. Drag to draw the Composition Zones item.

  3. To finish creating the Composition Zones item, choose Item > Share, or display the Content palette (Window menu) and click Add Item . Either way, the Shared Item Properties dialog box displays.

    Use the Shared Item Properties dialog box to name your composition layout, designate availability, and specify whether a tab displays at the bottom of the project window.
  4. Enter a name for the composition layout in the Name field.

  5. Choose This Project Only from the Availability drop-down menu.

  6. Click OK. The composition layout displays in the Content palette.

Placing a Composition Zones item

After you add a composition layout to the Content palette, you can place a Composition Zones item based on that composition layout onto a page. To place a Composition Zones item:

  1. Display the Content palette (Window menu).

    The Content palette lists composition layouts as well as other shared content.
  2. Select the composition layout you want to place.

  3. Drag the composition layout from the Content palette to the layout.

Managing multiple pages in a placed Composition Zones item

A composition layout may contain multiple pages. However, a Composition Zones item based on that composition layout can show only one page at a time. To indicate which page to show in a Composition Zones item:

  1. Select the Composition Zones item.

  2. Click on the Home Tab of the Measurements palette.

  3. Page drop-down list is displayed. You can choose any page number by selecting in drop-down list.

    Use the Page drop-down menu in the Home tab of the Measurements palette to display a specific page of a composition layout in your placed Composition Zones item.

     

Editing the attributes of a Composition Zones item

To edit the attributes of a Composition Zones item:

  1. Select a Composition Zones item.

  2. Click on the Home tab of the Measurements palette.

  3. Specify positioning, size, alignment, color, opacity, and printing ability.

  4. Use the Border, Runaround, and Drop Shadow tabs to make other structural adjustments.

  5. Use the Layout tab to navigate between pages, suppress or enable printing, and adjust layout opacity.

Converting a Composition Zones item to a picture

To create an external picture file from a Composition Zones item, choose Item > Composition Zones > Convert to Picture. This creates a picture appropriate for the layout type within which the Compositions Zones was created.

Before you convert a Composition Zones item to a picture, the Composition Zones item displays in the Composition Zones pane of the Usage dialog box (Utilities menu). But when you choose Item > Composition Zones > Convert to Picture, an alert indicates that the Composition Zones item will become unsynchronized. The resulting picture displays in the Picture pane of the Usage dialog box. However, the composition layout remains in the Content palette.

Unsynchronizing a Composition Zones item

When you unsynchronize a Composition Zones item, its composition layout remains available in your project. To unsynchronize a Composition Zones item:

  1. Select the Composition Zones item in the layout window.

  2. Choose Item > Unsynchronize. The composition layout remains in the Content palette for future use. But subsequent changes to the unsynchronized Composition Zones items in the layout window will not be synchronized.

Editing a composition layout: Content

When you edit a composition layout, you can change content and adjust layout-level attributes.

To edit the contents of a composition layout:

  1. Click the layout name in the layout tab at the bottom of the project window (available if Show Tab in Project Window is checked). If the composition layout name does not display in the layout tab, select the Item tool and double-click the Compositions Zones item.

  2. When the composition layout displays, all the composition layout contents are available for editing. You can use menu and palette commands to alter text, graphics, and items, and you can use tools to add content.

  3. Closing the window updates the content in the Composition Zones item.

Editing the contents of a composition layout

Your method for accessing a composition layout for editing is determined by your Show Tab in Project Window setting in the Advanced Layout Properties dialog box. When you check Show Tab in Project Window, you can access the composition layout from the layout tab at the top of the project window. Simply click the tab to activate the composition layout for editing content and layout attributes.

If you don't check Show Tab in Project Window, you have to select the Item tool and double click the original Composition Zones item. The composition layout displays.

For a composition layout created from an entire layout, check Show Tab in Project Window in the Advanced Layout Properties dialog box so you can access the layout easily. Otherwise, you have to select the composition layout in the Content palette, click Edit, and then check Show Tab in Project Window.

Unsynchronizing a composition layout

When you unsynchronize a composition layout, QuarkXPress breaks the link between that composition layout and all existing Composition Zones items based on that composition layout. To unsynchronize all instances of a Composition Zones items in a project, select the composition layout in the Content palette, and click the Unsynchronize All button . However, if you subsequently change the composition layout and place a new Composition Zones item based on it, the new Composition Zones item will reflect the change.

Deleting a composition layout

To delete a composition layout:

  1. Display the Content palette.

  2. Select the composition layout in the palette and click Delete .